aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2017-11-20 20:53:00 +0100
committerHarald Eilertsen <haraldei@anduin.net>2017-11-20 20:53:00 +0100
commitc65b9e00d5d37722e7e4887e7165e19931048c83 (patch)
tree139bb7d2b386cf3919b7be7cd3db39df08c75050 /Cargo.toml
parentba6d64efd3facfbe3865780292bf85ea0003ace6 (diff)
downloadrocket-blog-c65b9e00d5d37722e7e4887e7165e19931048c83.tar.gz
rocket-blog-c65b9e00d5d37722e7e4887e7165e19931048c83.tar.bz2
rocket-blog-c65b9e00d5d37722e7e4887e7165e19931048c83.zip
Use route decorators to produce different output formats.
This seems to be the more proper way of doing it. Also makes it much clearer which routes exists, and what formats they accept. Both in the code and in the status output.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7202391..762ce89 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,3 +16,8 @@ bart_derive = "0.1.4"
serde = "1.0"
serde_derive = "1.0"
serde_json = "1.0"
+
+[dependencies.rocket_contrib]
+version = "0.3.3"
+default-features = false
+features = ["json"]