aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2019-03-04 15:06:54 +0100
committerHarald Eilertsen <haraldei@anduin.net>2019-03-04 15:06:54 +0100
commitf93ff38767e23602108f86992c453f7973dd8bd0 (patch)
tree78cd8d2784e494d81f341983fffa73e9e845479f /Cargo.toml
parent59a44cd2629b424aa2723ba9f502bd7e455c6a1b (diff)
downloadramaskrik-social-f93ff38767e23602108f86992c453f7973dd8bd0.tar.gz
ramaskrik-social-f93ff38767e23602108f86992c453f7973dd8bd0.tar.bz2
ramaskrik-social-f93ff38767e23602108f86992c453f7973dd8bd0.zip
Set up database and connection pool with rocket_contrib::databases.
Set the env var DATABASE_URL before running the server. A .env file in the root of the project is also supported.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 08a340a..b9e3644 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,5 +5,10 @@ authors = ["haraldei"]
edition = "2018"
[dependencies]
+dotenv = "0.13.0"
rocket = "0.4.0"
-rocket_contrib = { version = "0.4.0", default-features = false, features = ["serve"] }
+
+[dependencies.rocket_contrib]
+version = "0.4.0"
+default-features = false
+features = ["serve", "diesel_postgres_pool"]