aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2019-04-02 22:55:59 +0200
committerHarald Eilertsen <haraldei@anduin.net>2019-04-02 22:55:59 +0200
commitb694e0f342ef4f2687afdcd7424dd4a0fe350799 (patch)
tree69f494b107f53fa3e491311a565ae365b93c1dc7 /Cargo.toml
parentb79d1453c4a8f999526d2af6238a1c2570c1e495 (diff)
downloadramaskrik-social-b694e0f342ef4f2687afdcd7424dd4a0fe350799.tar.gz
ramaskrik-social-b694e0f342ef4f2687afdcd7424dd4a0fe350799.tar.bz2
ramaskrik-social-b694e0f342ef4f2687afdcd7424dd4a0fe350799.zip
Refactor tests to always load fixtures, and sync execution.
Rust will run tests in parallel by default, which does not work too well with using db transactions as a means to isolate changes in the database between tests. So we have to run the database tests one at a time, thus the mutex.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 53f348c..973cedb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,4 +17,5 @@ default-features = false
features = ["json", "serve", "diesel_postgres_pool"]
[dev-dependencies]
+lazy_static = "~1.3.0"
serde_json = "~1.0.39"