aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2019-03-04 14:08:48 +0100
committerHarald Eilertsen <haraldei@anduin.net>2019-03-04 14:08:48 +0100
commit73c100ca9621ff9cfa3ca665e14e997524d92160 (patch)
tree5c9b5eef7872df679b0f286a762d4ff84d5a9b58 /Cargo.toml
parent0ecf1bf482b1db5e1e1fe07a5b21a57c084deb4e (diff)
downloadramaskrik-social-73c100ca9621ff9cfa3ca665e14e997524d92160.tar.gz
ramaskrik-social-73c100ca9621ff9cfa3ca665e14e997524d92160.tar.bz2
ramaskrik-social-73c100ca9621ff9cfa3ca665e14e997524d92160.zip
Use rocket_contrib StaticFiles module to serve static files.
This also changes the structure of the app quite significantly. Instead if generating the html for the index, we simply provide a public/index.html static file instead. For now this seems to make sense, it may not hold in the long run, but that's for another time to worry about.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1e03f2a..96df761 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,3 +7,4 @@ edition = "2018"
[dependencies]
askama = { version = "0.8.0", features = ["with-rocket"] }
rocket = "0.4.0"
+rocket_contrib = { version = "0.4.0", default-features = false, features = ["serve"] }