aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2019-05-09 22:04:15 +0200
committerHarald Eilertsen <haraldei@anduin.net>2019-05-09 22:04:15 +0200
commit4c489c4dd4ffaf74d718035f73fa3c0f762d1187 (patch)
treec1518a161bb7c603d3e4cb2ac4aae564fba70307 /Cargo.toml
parent5731358d3c1a4603d10be84557542d48dcc068a1 (diff)
downloadphisher-4c489c4dd4ffaf74d718035f73fa3c0f762d1187.tar.gz
phisher-4c489c4dd4ffaf74d718035f73fa3c0f762d1187.tar.bz2
phisher-4c489c4dd4ffaf74d718035f73fa3c0f762d1187.zip
Clean up socket on termination.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 181ffcf..b37a2b1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,5 +7,6 @@ edition = "2018"
[dependencies]
chrono = { version = "0.4.6", features = ["serde"] }
clap = "2.33"
+ctrlc = { version = "3.1.2", features = ["termination"] }
serde = { version = "1.0.91", features = ["derive"] }
serde_json = "1.0.39"