Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Deprecate and rename the keys for association restrict_dependent_destroy | Roque Pinel | 2015-07-20 | 1 | -2/+2 |
| | | | | | | | | | | | | | | | | | Previously `has_one` and `has_many` associations were using the `one` and `many` keys respectively. Both of these keys have special meaning in I18n (they are considered to be pluralizations) so by renaming them to `has_one` and `has_many` we make the messages more explicit and most importantly they don't clash with linguistical systems that need to validate translation keys (and their pluralizations). The `:'restrict_dependent_destroy.one'` key should be replaced with `:'restrict_dependent_destroy.has_one'`, and `:'restrict_dependent_destroy.many'` with `:'restrict_dependent_destroy.has_many'`. [Roque Pinel & Christopher Dell] | ||||
* | Move required error message and changelog to Active Record | Carlos Antonio da Silva | 2015-02-01 | 1 | -0/+1 |
| | | | | | The new association error belongs to Active Record, not Active Model. See #18700 for reference. | ||||
* | Changed scope for "taken" error message translation to decrease precedence | Andrew DiMichele | 2012-10-19 | 1 | -1/+5 |
| | | | | | | Moved activerecord.errors.messages.taken to errors.messages.taken so that translations for, e.g., errors.attributes.email.taken don't get overridden. Test that the translation for 'taken' can be overridden | ||||
* | Fix typo | Rafael Mendonça França | 2012-02-01 | 1 | -1/+1 |
| | |||||
* | Use human attribute name to show the dependent destroy message | Rafael Mendonça França | 2012-02-01 | 1 | -1/+1 |
| | |||||
* | fix has_one, has_many restrict error message | Manoj | 2012-02-01 | 1 | -1/+3 |
| | |||||
* | suggested fixes for :dependent => :restrict deprecation. | Manoj | 2012-01-31 | 1 | -1/+1 |
| | |||||
* | has_many/has_one, :dependent => :restrict, deprecation added. | Manoj | 2012-01-29 | 1 | -0/+1 |
| | |||||
* | Deletes trailing whitespaces (over text files only find * -type f -exec sed ↵ | Santiago Pastorino | 2010-08-14 | 1 | -2/+2 |
| | | | | 's/[ \t]*$//' -i {} \;) | ||||
* | edit pass: the names of Rails components have a space, ie, "Active Record", ↵ | Xavier Noria | 2010-06-14 | 1 | -1/+1 |
| | | | | not "ActiveRecord" | ||||
* | Use %{} syntax in I18n (faster) instead of {{}}. | José Valim | 2010-05-01 | 1 | -2/+2 |
| | |||||
* | Drop AR I18n deprecation and simple use errors.messages as fallback. | José Valim | 2010-01-30 | 1 | -12/+12 |
| | |||||
* | Allow to specify default attributes names translation in I18n yml files. | José Valim | 2010-01-07 | 1 | -0/+5 |
| | | | | | | | | | | | | For example, you could easily specify :created_at and :updated_at translations as: en: attributes: created_at: "Created at" updated_at: "Updated at" This configuration is built on ActiveModel, so it means those translations are shared between different ORMs as well (but always as a fallback). | ||||
* | Errors messages are now moved from :activerecord.errors to simply :errors on ↵ | José Valim | 2010-01-07 | 1 | -31/+8 |
| | | | | I18n yml files. | ||||
* | Use activerecord.errors.format as in Rails 2.3.5. | José Valim | 2010-01-02 | 1 | -0/+3 |
| | |||||
* | allow ActiveRecord#RecordInvalid exception message to be localized | Sven Fuchs | 2009-08-26 | 1 | -0/+1 |
| | | | | | | [#2754 state:committed] Signed-off-by: Jeremy Kemper <jeremy@bitsweat.net> | ||||
* | Merge docrails | Pratik Naik | 2009-01-18 | 1 | -1/+1 |
| | |||||
* | use :en as a default locale (in favor of :en-US) | Sven Fuchs | 2008-11-18 | 1 | -1/+1 |
| | | | | Signed-off-by: David Heinemeier Hansson <david@loudthinking.com> | ||||
* | Merge docrails | Pratik Naik | 2008-09-13 | 1 | -4/+25 |
| | |||||
* | Removed en-US ruby locale in favor of yaml | Iain Hecker | 2008-08-20 | 1 | -28/+0 |
| | |||||
* | Locale file changed to yaml | Iain Hecker | 2008-08-20 | 1 | -0/+33 |
| | |||||
* | Cleaned up ActiveRecord i18n scoping | Iain Hecker | 2008-08-14 | 1 | -23/+25 |
| | |||||
* | switch to using I18n.load_translations instead of requiring plain ruby files | Sven Fuchs | 2008-08-13 | 1 | -23/+24 |
| | |||||
* | Renamed lang/ to locale/ because that's what we seem to | Sven Fuchs | 2008-06-21 | 1 | -0/+25 |
standarize on. Also, in future this place can be used for data/code that's not literally translations but conceptually belongs to the locale (like custom pluralization algorithms etc.). |