aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2018-12-26 15:51:08 +0100
committerHarald Eilertsen <haraldei@anduin.net>2018-12-26 15:58:57 +0100
commit81acfc65ededd306a8c2b46d483caee8244c52ca (patch)
treefae2a557e6c76aace05e8f66ca0af5f9f871b59c /Cargo.toml
parent0e06b4193369dbbc851974e2d22390dea2976f6f (diff)
downloadprimstav-81acfc65ededd306a8c2b46d483caee8244c52ca.tar.gz
primstav-81acfc65ededd306a8c2b46d483caee8244c52ca.tar.bz2
primstav-81acfc65ededd306a8c2b46d483caee8244c52ca.zip
Use serde_derive to deserialize primstav data into a struct.
This makes it much easier to work with the data. Adds some restrictions on the yaml data though, all elements must be present, even if empty.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 81c7ed8..958872d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,4 +6,6 @@ edition = "2018"
[dependencies]
chrono = "0.4.6"
+serde = "*"
+serde_derive = "*"
serde_yaml = "0.8.8"