aboutsummaryrefslogtreecommitdiffstats
path: root/doc/en/hook/system_app_installed_filter.bb
diff options
context:
space:
mode:
Diffstat (limited to 'doc/en/hook/system_app_installed_filter.bb')
-rw-r--r--doc/en/hook/system_app_installed_filter.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/en/hook/system_app_installed_filter.bb b/doc/en/hook/system_app_installed_filter.bb
new file mode 100644
index 000000000..a269a79a8
--- /dev/null
+++ b/doc/en/hook/system_app_installed_filter.bb
@@ -0,0 +1,18 @@
+[h2]system_app_installed_filter[/h2]
+
+Allow plugins to filter the result of system_app_installed.
+
+Code excerpt:
+
+[code]
+ $filter_arr = [
+ 'uid'=>$uid,
+ 'app'=>$app,
+ 'installed'=>$r
+ ];
+ call_hooks('system_app_installed_filter',$filter_arr);
+ $r = $filter_arr['installed'];
+[/code]
+
+cxref: Zotlabs/Lib/Apps.php
+