aboutsummaryrefslogtreecommitdiffstats
path: root/doc/en/hook/item_stored.bb
diff options
context:
space:
mode:
Diffstat (limited to 'doc/en/hook/item_stored.bb')
-rw-r--r--doc/en/hook/item_stored.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/en/hook/item_stored.bb b/doc/en/hook/item_stored.bb
new file mode 100644
index 000000000..8d706cb4e
--- /dev/null
+++ b/doc/en/hook/item_stored.bb
@@ -0,0 +1,18 @@
+[h2]item_stored[/h2]
+
+Allow addons to continue processing after an item has been stored in the event
+that they need access to the item_id or other data that gets assigned during
+the storage process.
+
+It is fed an array of type item (including terms and iconfig data).
+
+[code]
+ /**
+ * @hooks item_stored
+ * Called after new item is stored in the database.
+ * (By this time we have an item_id and other frequently needed info.)
+ */
+ call_hooks('item_stored',$arr);
+[/code]
+
+see: include/items.php