aboutsummaryrefslogtreecommitdiffstats
path: root/doc/en/hook/app_installed_filter.bb
diff options
context:
space:
mode:
Diffstat (limited to 'doc/en/hook/app_installed_filter.bb')
-rw-r--r--doc/en/hook/app_installed_filter.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/doc/en/hook/app_installed_filter.bb b/doc/en/hook/app_installed_filter.bb
new file mode 100644
index 000000000..f0d91d6f0
--- /dev/null
+++ b/doc/en/hook/app_installed_filter.bb
@@ -0,0 +1,17 @@
+[h2]app_installed_filter[/h2]
+
+Allow plugins to filter the result of app_installed.
+
+Code excerpt:
+
+[code]
+ $filter_arr = [
+ 'uid'=>$uid,
+ 'app'=>$app,
+ 'installed'=>$r
+ ];
+ call_hooks('app_installed_filter',$filter_arr);
+ $r = $filter_arr['installed'];
+[/code]
+
+cxref: Zotlabs/Lib/Apps.php