aboutsummaryrefslogtreecommitdiffstats
path: root/doc/developer_function_primer.bb
diff options
context:
space:
mode:
Diffstat (limited to 'doc/developer_function_primer.bb')
-rw-r--r--doc/developer_function_primer.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/doc/developer_function_primer.bb b/doc/developer_function_primer.bb
index 48af9523d..f39954d73 100644
--- a/doc/developer_function_primer.bb
+++ b/doc/developer_function_primer.bb
@@ -20,10 +20,14 @@ returns an xchan structure representing the current viewer if authenticated (loc
Returns the config setting for $family and $key or false if unset.
+Deprecated: Use Zotlabs\Lib\Config::Get instead.
+
[b] set_config($family,$key,$value), set_pconfig($uid,$family,$key,$value)[/b]
Sets the value of config setting for $family and $key to $value. Returns $value. The config versions operate on system-wide settings. The pconfig versions get/set the values for a specific integer uid (channel_id). The xconfig version get/sets the value for a specific xchan hash - generally used for remote users.
+Deprecated: Use Zotlabs\Lib\Config::Set instead.
+
[b]dbesc()[/b]
Always escape strings being used in DB queries. This function returns the escaped string. Integer DB parameters should all be proven integers by wrapping with intval()