aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hook/system_app_installed_filter.bb
diff options
context:
space:
mode:
authorzotlabs <mike@macgirvin.com>2018-10-04 19:20:10 -0700
committerzotlabs <mike@macgirvin.com>2018-10-04 19:20:10 -0700
commit3a0a611f15f2789099acf57c6ca93828f5edae46 (patch)
treed928cd86bc856ae80a95a9738fc8a96b8fa23e5b /doc/hook/system_app_installed_filter.bb
parentd33c331abd3ae500fc7cdac206ea647c4c71905e (diff)
parent1eaf6df842184743ee20ec69931be1ff7136f34e (diff)
downloadvolse-hubzilla-3a0a611f15f2789099acf57c6ca93828f5edae46.tar.gz
volse-hubzilla-3a0a611f15f2789099acf57c6ca93828f5edae46.tar.bz2
volse-hubzilla-3a0a611f15f2789099acf57c6ca93828f5edae46.zip
Merge branch 'dev'
Diffstat (limited to 'doc/hook/system_app_installed_filter.bb')
-rw-r--r--doc/hook/system_app_installed_filter.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/hook/system_app_installed_filter.bb b/doc/hook/system_app_installed_filter.bb
new file mode 100644
index 000000000..a269a79a8
--- /dev/null
+++ b/doc/hook/system_app_installed_filter.bb
@@ -0,0 +1,18 @@
+[h2]system_app_installed_filter[/h2]
+
+Allow plugins to filter the result of system_app_installed.
+
+Code excerpt:
+
+[code]
+ $filter_arr = [
+ 'uid'=>$uid,
+ 'app'=>$app,
+ 'installed'=>$r
+ ];
+ call_hooks('system_app_installed_filter',$filter_arr);
+ $r = $filter_arr['installed'];
+[/code]
+
+cxref: Zotlabs/Lib/Apps.php
+