aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hook/item_stored_update.bb
diff options
context:
space:
mode:
authorzotlabs <mike@macgirvin.com>2018-12-17 18:45:42 -0800
committerzotlabs <mike@macgirvin.com>2018-12-17 18:45:42 -0800
commit15ce8bc79b219e10f709796c09c739649a8df53b (patch)
treeedd456a39ad0daf12d6cc4409a99477f4fb38d82 /doc/hook/item_stored_update.bb
parent8d70b919551f6f6462e639f7cfffda9825344e43 (diff)
parentd190b1995b0886b430beb5dac1a1e72582b9ad2b (diff)
downloadvolse-hubzilla-15ce8bc79b219e10f709796c09c739649a8df53b.tar.gz
volse-hubzilla-15ce8bc79b219e10f709796c09c739649a8df53b.tar.bz2
volse-hubzilla-15ce8bc79b219e10f709796c09c739649a8df53b.zip
Merge branch 'dev' of https://framagit.org/hubzilla/core into xdev_merge
Diffstat (limited to 'doc/hook/item_stored_update.bb')
-rw-r--r--doc/hook/item_stored_update.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/doc/hook/item_stored_update.bb b/doc/hook/item_stored_update.bb
new file mode 100644
index 000000000..4532a347c
--- /dev/null
+++ b/doc/hook/item_stored_update.bb
@@ -0,0 +1,15 @@
+[h2]item_stored_update[/h2]
+
+Allow addons to continue processing after an item update has been stored
+
+It is fed an array of type item (including terms and iconfig data).
+
+[code]
+ /**
+ * @hooks item_stored_update
+ * Called after updated item is stored in the database.
+ */
+ call_hooks('item_stored_update',$arr);
+[/code]
+
+see: include/items.php