aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hook/item_stored_update.bb
diff options
context:
space:
mode:
authorDM42.Net (Matt Dent) <dentm42@dm42.net>2018-12-14 20:20:26 -0500
committerDM42.Net (Matt Dent) <dentm42@dm42.net>2018-12-14 20:20:26 -0500
commit09b2cdd618217c2dfc0149579ce1780c201a50ea (patch)
treec32cba336c19e08f5ec2fc4389c176b52ca1adf0 /doc/hook/item_stored_update.bb
parentf81a3ba45d50c0a0e4da68c17aba73425058e23d (diff)
downloadvolse-hubzilla-09b2cdd618217c2dfc0149579ce1780c201a50ea.tar.gz
volse-hubzilla-09b2cdd618217c2dfc0149579ce1780c201a50ea.tar.bz2
volse-hubzilla-09b2cdd618217c2dfc0149579ce1780c201a50ea.zip
Add ITEM_TYPE_CUSTOM and hooks for processing custom item types
Diffstat (limited to 'doc/hook/item_stored_update.bb')
-rw-r--r--doc/hook/item_stored_update.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/doc/hook/item_stored_update.bb b/doc/hook/item_stored_update.bb
new file mode 100644
index 000000000..4532a347c
--- /dev/null
+++ b/doc/hook/item_stored_update.bb
@@ -0,0 +1,15 @@
+[h2]item_stored_update[/h2]
+
+Allow addons to continue processing after an item update has been stored
+
+It is fed an array of type item (including terms and iconfig data).
+
+[code]
+ /**
+ * @hooks item_stored_update
+ * Called after updated item is stored in the database.
+ */
+ call_hooks('item_stored_update',$arr);
+[/code]
+
+see: include/items.php