aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hook/item_custom.bb
diff options
context:
space:
mode:
authorzotlabs <mike@macgirvin.com>2018-12-17 18:45:42 -0800
committerzotlabs <mike@macgirvin.com>2018-12-17 18:45:42 -0800
commit15ce8bc79b219e10f709796c09c739649a8df53b (patch)
treeedd456a39ad0daf12d6cc4409a99477f4fb38d82 /doc/hook/item_custom.bb
parent8d70b919551f6f6462e639f7cfffda9825344e43 (diff)
parentd190b1995b0886b430beb5dac1a1e72582b9ad2b (diff)
downloadvolse-hubzilla-15ce8bc79b219e10f709796c09c739649a8df53b.tar.gz
volse-hubzilla-15ce8bc79b219e10f709796c09c739649a8df53b.tar.bz2
volse-hubzilla-15ce8bc79b219e10f709796c09c739649a8df53b.zip
Merge branch 'dev' of https://framagit.org/hubzilla/core into xdev_merge
Diffstat (limited to 'doc/hook/item_custom.bb')
-rw-r--r--doc/hook/item_custom.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/doc/hook/item_custom.bb b/doc/hook/item_custom.bb
new file mode 100644
index 000000000..d20c7d76c
--- /dev/null
+++ b/doc/hook/item_custom.bb
@@ -0,0 +1,24 @@
+[h2]item_custom[/h2]
+
+Allow addons to create and process custom item types.
+
+Addon authors will need to use iconfig meta data (with sharing on) or some other method
+to specify and determine whether the custom item is destined for their addon.
+
+It is fed an array of ['item' => ${item_array}, 'allow_exec' => {true/false}]
+
+By default $arr['item']['cancel'] is set to TRUE which will abort storage of the
+custom item in the item table unless the addon unsets it or sets it to false.
+
+[code]
+ if ($arr['item_type']==ITEM_TYPE_CUSTOM) {
+ /* Custom items are not stored by default
+ because they require an addon to process. */
+ $d['item']['cancel']=true;
+
+ call_hooks('item_custom',$d);
+ }
+
+[/code]
+
+see: include/items.php