aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hook/dropdown_extras.bb
diff options
context:
space:
mode:
authorM.Dent (DM42.Net) <dentm42@gmail.com>2018-09-19 21:18:06 -0400
committerM.Dent (DM42.Net) <dentm42@gmail.com>2018-09-19 21:18:06 -0400
commitf2c59b3881d50dce907821054d9b79df4d009827 (patch)
treef53cf1743e28008a371eb19c0d8fb2dc2c18453e /doc/hook/dropdown_extras.bb
parent34fec995f711b03bc19580ee9e57c22712cf51df (diff)
downloadvolse-hubzilla-f2c59b3881d50dce907821054d9b79df4d009827.tar.gz
volse-hubzilla-f2c59b3881d50dce907821054d9b79df4d009827.tar.bz2
volse-hubzilla-f2c59b3881d50dce907821054d9b79df4d009827.zip
Document new hooks
Diffstat (limited to 'doc/hook/dropdown_extras.bb')
-rw-r--r--doc/hook/dropdown_extras.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/doc/hook/dropdown_extras.bb b/doc/hook/dropdown_extras.bb
new file mode 100644
index 000000000..6d7110a76
--- /dev/null
+++ b/doc/hook/dropdown_extras.bb
@@ -0,0 +1,17 @@
+[h2]dropdown_extras[/h2]
+
+Modify the dropdown menu available through the cog of items as displayed by conv_item.tpl
+
+This hook allows plugins to add arbitrary html to the cog dropdown of thread items displayed with the conv_item.tpl template.
+
+It is fed an array of ['item' => $item, 'dropdown_extras' => '']. Any additions to the cog menu should be prepended/appended to
+the ['dropdown_extras'] element.
+
+[code]
+$dropdown_extras_arr = [ 'item' => $item , 'dropdown_extras' => '' ];
+call_hooks('dropdown_extras',$dropdown_extras_arr);
+$dropdown_extras = $dropdown_extras_arr['dropdown_extras'];
+[/code]
+
+see: Zotlabs/Lib/ThreadItem.php
+see: view/tpl/conv_item.tpl