aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hook/check_account_password.bb
diff options
context:
space:
mode:
authorMario <mario@mariovavti.com>2024-03-22 08:37:29 +0000
committerMario <mario@mariovavti.com>2024-03-22 08:37:29 +0000
commit1aeb05628b6a2a069c46980efbe628362c9e3e74 (patch)
treee9aed15d0cd74e0c23dcb05c7be8fe9541efdf36 /doc/hook/check_account_password.bb
parent5b7387459cf4de8f7354d81cb0392c4225714d94 (diff)
parentb464fae3bf22585888c5f3def8eded76fd48ed16 (diff)
downloadvolse-hubzilla-9.0.tar.gz
volse-hubzilla-9.0.tar.bz2
volse-hubzilla-9.0.zip
Merge branch '9.0RC'9.0
Diffstat (limited to 'doc/hook/check_account_password.bb')
-rw-r--r--doc/hook/check_account_password.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/doc/hook/check_account_password.bb b/doc/hook/check_account_password.bb
index 53562ec6e..ce5202f48 100644
--- a/doc/hook/check_account_password.bb
+++ b/doc/hook/check_account_password.bb
@@ -1 +1,17 @@
[h2]check_account_password[/h2]
+Use this hook to provide additional checks or validations of the password given when
+registering and account.
+[h3]Arguments:[/h3]
+[code=php]array(
+ 'password' => $password, // The password to check
+ 'result' => array(
+ 'error' => false,
+ 'message' => ''
+ )
+)[/code]
+[h3]Results:[/h3]
+For a failed check set the [code]error[/code] member of the [code]result[/code]
+array to [code]true[/code] and the [code]message[/code] to a short message
+explaining why it failed.
+
+Otherwise, leave it alone.