aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hook/authenticate.bb
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2024-04-30 06:59:19 +0000
committerMario <mario@mariovavti.com>2024-04-30 06:59:19 +0000
commit7c34a3676d294c9a1acc69f71ab3061074509160 (patch)
treead04cef0d545c5e5e24e76060b6c32d65363d48e /doc/hook/authenticate.bb
parent48cec945051d259a06871d937ad998a1bd3e22ec (diff)
downloadvolse-hubzilla-7c34a3676d294c9a1acc69f71ab3061074509160.tar.gz
volse-hubzilla-7c34a3676d294c9a1acc69f71ab3061074509160.tar.bz2
volse-hubzilla-7c34a3676d294c9a1acc69f71ab3061074509160.zip
Rework Help module + begin tests for Setup module
Diffstat (limited to 'doc/hook/authenticate.bb')
-rw-r--r--doc/hook/authenticate.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/doc/hook/authenticate.bb b/doc/hook/authenticate.bb
deleted file mode 100644
index eb8071e73..000000000
--- a/doc/hook/authenticate.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-[h2]authenticate[/h2]
-
-Invoked when a POST request is made with non-null $_POST['auth-params'] such as from the login form.
-If the hook handler does not set the 'authenticated' parameter of the passed array, normal login functions continue;
-
-The 'user_record' is in fact an account DB record. To provide automatic provisioning of accounts from other authentication realms, this record should be generated and stored during the verification phase.
-
-
-[code]
- $addon_auth = array(
- 'username' => trim($_POST['username']),
- 'password' => trim($_POST['password']),
- 'authenticated' => 0,
- 'user_record' => null
- );
-
- /**
- *
- * A plugin indicates successful login by setting 'authenticated' to non-zero value and returning a user record
- * Plugins should never set 'authenticated' except to indicate success - as hooks may be chained
- * and later plugins should not interfere with an earlier one that succeeded.
- *
- */
-
- call_hooks('authenticate', $addon_auth);
-[/code]
-
-
-See include/auth.php