aboutsummaryrefslogtreecommitdiffstats
path: root/doc/en/hook/dropdown_extras.bb
diff options
context:
space:
mode:
authorMario <mario@mariovavti.com>2024-04-30 06:59:20 +0000
committerMario <mario@mariovavti.com>2024-04-30 06:59:20 +0000
commitce15852b9a57a6c77531186ed24a389ebce8524e (patch)
treead04cef0d545c5e5e24e76060b6c32d65363d48e /doc/en/hook/dropdown_extras.bb
parent48cec945051d259a06871d937ad998a1bd3e22ec (diff)
parent7c34a3676d294c9a1acc69f71ab3061074509160 (diff)
downloadvolse-hubzilla-ce15852b9a57a6c77531186ed24a389ebce8524e.tar.gz
volse-hubzilla-ce15852b9a57a6c77531186ed24a389ebce8524e.tar.bz2
volse-hubzilla-ce15852b9a57a6c77531186ed24a389ebce8524e.zip
Merge branch 'rework-help-module' into 'dev'
Rework Help module + begin tests for Setup module See merge request hubzilla/core!2120
Diffstat (limited to 'doc/en/hook/dropdown_extras.bb')
-rw-r--r--doc/en/hook/dropdown_extras.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/doc/en/hook/dropdown_extras.bb b/doc/en/hook/dropdown_extras.bb
new file mode 100644
index 000000000..6d7110a76
--- /dev/null
+++ b/doc/en/hook/dropdown_extras.bb
@@ -0,0 +1,17 @@
+[h2]dropdown_extras[/h2]
+
+Modify the dropdown menu available through the cog of items as displayed by conv_item.tpl
+
+This hook allows plugins to add arbitrary html to the cog dropdown of thread items displayed with the conv_item.tpl template.
+
+It is fed an array of ['item' => $item, 'dropdown_extras' => '']. Any additions to the cog menu should be prepended/appended to
+the ['dropdown_extras'] element.
+
+[code]
+$dropdown_extras_arr = [ 'item' => $item , 'dropdown_extras' => '' ];
+call_hooks('dropdown_extras',$dropdown_extras_arr);
+$dropdown_extras = $dropdown_extras_arr['dropdown_extras'];
+[/code]
+
+see: Zotlabs/Lib/ThreadItem.php
+see: view/tpl/conv_item.tpl