aboutsummaryrefslogtreecommitdiffstats
path: root/doc/en/api/statuses_update.bb
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2024-04-30 06:59:19 +0000
committerMario <mario@mariovavti.com>2024-04-30 06:59:19 +0000
commit7c34a3676d294c9a1acc69f71ab3061074509160 (patch)
treead04cef0d545c5e5e24e76060b6c32d65363d48e /doc/en/api/statuses_update.bb
parent48cec945051d259a06871d937ad998a1bd3e22ec (diff)
downloadvolse-hubzilla-7c34a3676d294c9a1acc69f71ab3061074509160.tar.gz
volse-hubzilla-7c34a3676d294c9a1acc69f71ab3061074509160.tar.bz2
volse-hubzilla-7c34a3676d294c9a1acc69f71ab3061074509160.zip
Rework Help module + begin tests for Setup module
Diffstat (limited to 'doc/en/api/statuses_update.bb')
-rw-r--r--doc/en/api/statuses_update.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/doc/en/api/statuses_update.bb b/doc/en/api/statuses_update.bb
new file mode 100644
index 000000000..acad440de
--- /dev/null
+++ b/doc/en/api/statuses_update.bb
@@ -0,0 +1,23 @@
+[h2]statuses/update[/h2]
+Parameters
+
+ title: Title of the status
+ status: Status in text [or bbcode] format
+ htmlstatus: Status in HTML format
+ in_reply_to_status_id
+ lat: latitude
+ long: longitude
+ media: image data
+ source: Application name
+ group_allow
+ contact_allow
+ group_deny
+ contact_deny
+
+
+Example
+
+[code]
+curl -u theUsername:thePassword http://mywebsite/api/statuses/update.xml -d status='Hello world'
+[/code]
+