aboutsummaryrefslogtreecommitdiffstats
path: root/doc/developer_function_primer.bb
diff options
context:
space:
mode:
authorMario <mario@mariovavti.com>2024-03-24 09:58:21 +0000
committerMario <mario@mariovavti.com>2024-03-24 09:58:21 +0000
commita0cfe22501dc9daa7dd8cff86803cf494a1f5ec3 (patch)
treee156db21df2251b8c67e61453c8f4af9f9460d2f /doc/developer_function_primer.bb
parentecdd9a4d6edd769a3e2c3b0604e4637d94fa1a51 (diff)
parent0dc959d9fe40bddce5e99b8162bb0e770fc28ed9 (diff)
downloadvolse-hubzilla-a0cfe22501dc9daa7dd8cff86803cf494a1f5ec3.tar.gz
volse-hubzilla-a0cfe22501dc9daa7dd8cff86803cf494a1f5ec3.tar.bz2
volse-hubzilla-a0cfe22501dc9daa7dd8cff86803cf494a1f5ec3.zip
Merge branch 'deprecate-include-config-in-core' into 'dev'
Deprecate *_config() functions in core. See merge request hubzilla/core!2114
Diffstat (limited to 'doc/developer_function_primer.bb')
-rw-r--r--doc/developer_function_primer.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/doc/developer_function_primer.bb b/doc/developer_function_primer.bb
index 48af9523d..f39954d73 100644
--- a/doc/developer_function_primer.bb
+++ b/doc/developer_function_primer.bb
@@ -20,10 +20,14 @@ returns an xchan structure representing the current viewer if authenticated (loc
Returns the config setting for $family and $key or false if unset.
+Deprecated: Use Zotlabs\Lib\Config::Get instead.
+
[b] set_config($family,$key,$value), set_pconfig($uid,$family,$key,$value)[/b]
Sets the value of config setting for $family and $key to $value. Returns $value. The config versions operate on system-wide settings. The pconfig versions get/set the values for a specific integer uid (channel_id). The xconfig version get/sets the value for a specific xchan hash - generally used for remote users.
+Deprecated: Use Zotlabs\Lib\Config::Set instead.
+
[b]dbesc()[/b]
Always escape strings being used in DB queries. This function returns the escaped string. Integer DB parameters should all be proven integers by wrapping with intval()