aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2018-08-21 22:21:15 +0200
committerHarald Eilertsen <haraldei@anduin.net>2018-08-21 22:21:15 +0200
commitb1e19406051360bdf2d50a62886103e290ee336d (patch)
tree29b82685a8a7b4c470c3df168510b2fe71b2ae5d /Cargo.toml
parentb54b523458a4f432874051490e1873e1d7f396ed (diff)
downloadrust-zotapi-b1e19406051360bdf2d50a62886103e290ee336d.tar.gz
rust-zotapi-b1e19406051360bdf2d50a62886103e290ee336d.tar.bz2
rust-zotapi-b1e19406051360bdf2d50a62886103e290ee336d.zip
Add support for fetching xchan data by address.
Not entirely happy with it, have updated the signature of Client::fetch_stream and Client::url to take args, which are left out if they're not serializable (or empty, I hope.) Should probably use an Option instead, or maybe even two entry points for the api.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ec8f852..8713632 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,6 +22,7 @@ authors = ["haraldei"]
[dependencies]
reqwest = "0.8"
serde = "1.0"
+serde_urlencoded = "0.5.1"
[dev-dependencies]
dotenv = "0.13"