Commit message (Collapse) | Author | Age | Files | Lines | ||
---|---|---|---|---|---|---|
... | ||||||
* | | url_for: avoid a nil check. unroll a loop. handle most common case 1st. | ara.t.howard | 2012-04-05 | 1 | -18/+13 | |
| | | ||||||
* | | carefully and quickly merge url_for options | ara.t.howard | 2012-04-04 | 1 | -1/+17 | |
| | | ||||||
* | | Updated/changed useless tr/gsubs | Jurriaan Pruis | 2012-04-03 | 1 | -2/+2 | |
| | | ||||||
* | | Merge branch 'master' of github.com:lifo/docrails | Vijay Dev | 2012-03-27 | 1 | -0/+19 | |
|\ \ | ||||||
| * | | add missing do [ci skip] | Vijay Dev | 2012-03-27 | 1 | -1/+1 | |
| | | | ||||||
| * | | added shallow_prefix option description in documantation | Lukasz Sarnacki | 2012-03-27 | 1 | -0/+19 | |
| | | | | | | | | | | | | It is in response for confusion in issue #5301 | |||||
* | | | Allow a defining custom member field on resources | Jamie Macey | 2012-03-25 | 1 | -4/+5 | |
|/ / | | | | | | | | | | | | | | | | | | | By default, resources routes are created with :resource/:id. A model defining to_param can make prettier urls by using something more readable than an integer ID, but since the route picks it up as :id you wind up with awkward User.find_by_username(params[:id]) calls. By overriding the key to be used in @request.params you can be more obvious in your intent. | |||||
* | | Add missing require | Santiago Pastorino | 2012-03-17 | 1 | -0/+1 | |
| | | ||||||
* | | Remove unused require | Santiago Pastorino | 2012-03-17 | 1 | -1/+0 | |
| | | ||||||
* | | Route root helper shortcut | Brian Cardarella | 2012-03-03 | 1 | -0/+5 | |
| | | | | | | | | Allow the root route helper to accept just a string | |||||
* | | don't pass unnecessary argument | Sergey Nartimov | 2012-03-02 | 1 | -2/+2 | |
| | | ||||||
* | | Optimize url helpers. | Sergey Nartimov + José Valim | 2012-03-02 | 2 | -11/+13 | |
| | | ||||||
* | | Optimize path helpers. | José Valim | 2012-03-02 | 3 | -12/+64 | |
| | | ||||||
* | | Merge pull request #5219 from ↵ | Aaron Patterson | 2012-02-29 | 1 | -0/+2 | |
|\ \ | | | | | | | | | | | | | mattfawcett/2781-fix-querystring-route-constraint-for-testing Fix for #2781 | |||||
| * | | Fix the assert_recognizes test method so that it works when there are | Matt Fawcett | 2012-02-24 | 1 | -0/+2 | |
| | | | | | | | | | | | | constraints on the querystring. Issue #2781 | |||||
* | | | Merge branch 'master' of github.com:lifo/docrails | Vijay Dev | 2012-02-25 | 1 | -1/+1 | |
|\ \ \ | | | | | | | | | | | | | | | | | Conflicts: actionmailer/CHANGELOG.md | |||||
| * | | | Fix typo in match :to docs | Justin Woodbridge | 2012-02-23 | 1 | -1/+1 | |
| | | | | ||||||
* | | | | consistently mention first patch, then put | Xavier Noria | 2012-02-24 | 1 | -7/+7 | |
| | | | | | | | | | | | | | | | | | | | | | | | | There was a mix, sometimes patch first, sometimes put first. Use always patch first, since this is going to be the primary verb for updates. | |||||
* | | | | uses PATCH for the forms of persisted records, and routes PATCH and PUT to ↵ | Xavier Noria | 2012-02-24 | 1 | -9/+8 | |
| |/ / |/| | | | | | | | | the update action of resources | |||||
* | | | Avoid inspecting the whole route set, closes #1525 | José Valim | 2012-02-23 | 1 | -0/+6 | |
| | | | ||||||
* | | | Merge pull request #5084 from johndouthat/patch-1 | Aaron Patterson | 2012-02-22 | 1 | -2/+1 | |
|\ \ \ | | | | | | | | | Remove reference to rails_legacy_mapper, which isn't compatible with 3.2... | |||||
| * | | | Remove reference to rails_legacy_mapper, which isn't compatible with 3.2 #5022 | johndouthat | 2012-02-18 | 1 | -2/+1 | |
| |/ / | ||||||
* | | | Fix routes inspection order | Rafael Mendonça França | 2012-02-22 | 1 | -2/+2 | |
| | | | ||||||
* | | | Add config.default_method_for_update to support PATCH | David Lee | 2012-02-22 | 1 | -54/+71 | |
|/ / | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | PATCH is the correct HTML verb to map to the #update action. The semantics for PATCH allows for partial updates, whereas PUT requires a complete replacement. Changes: * adds config.default_method_for_update you can set to :patch * optionally use PATCH instead of PUT in resource routes and forms * adds the #patch verb to routes to detect PATCH requests * adds #patch? to Request * changes documentation and comments to indicate support for PATCH This change maintains complete backwards compatibility by keeping :put as the default for config.default_method_for_update. | |||||
* | | Fix GH #4720. Routing problem with nested namespace and already camelized ↵ | kennyj | 2012-02-10 | 1 | -0/+5 | |
| | | | | | | | | controller option. | |||||
* | | Fix match docs | Rafael Mendonça França | 2012-02-07 | 1 | -1/+1 | |
| | | ||||||
* | | Fixed force_ssl redirects to include original query params | Ryan McGeary | 2012-02-07 | 1 | -0/+1 | |
| | | | | | | | | | | | | | | | | | | | | `ActionController.force_ssl` redirects http URLs to their https equivalent; however, when a URL contains a query string, the resulting redirect lacked the original query string. Conflicts: actionpack/lib/action_controller/metal/force_ssl.rb | |||||
* | | Fix url_for method's behavior when it is called with :controller option ↵ | kennyj | 2012-02-07 | 1 | -1/+1 | |
| | | | | | | | | | | | | which starts with "/" from multiple nested controller. Closes #3864 | |||||
* | | Note the ways #match may be called | Jeremy Kemper | 2012-02-05 | 1 | -0/+3 | |
| | | ||||||
* | | Revert "Deprecated multi args to http route methods" | Jeremy Kemper | 2012-02-05 | 1 | -11/+0 | |
| | | | | | | | | | | | | | | | | | | | | Too painful to lose the compact shorthand form! This reverts commit e848c52535fa0f9488cdbdb3f1cedc7c7c02d643. Conflicts: actionpack/lib/action_dispatch/routing/mapper.rb | |||||
* | | Fix typo in routing documentation | Wen-Tien Chang | 2012-02-01 | 1 | -1/+1 | |
| | | ||||||
* | | Merge pull request #3775 from karevn/master | Aaron Patterson | 2012-01-24 | 1 | -1/+2 | |
|\ \ | | | | | | | Please pull my changes - they fix a rare problem with tests framework | |||||
| * | | Fix: when using subdomains and constraints, request params were not passed ↵ | karevn | 2011-11-28 | 1 | -1/+2 | |
| | | | | | | | | | | | | to constraints callback | |||||
* | | | initialized the @segment_keys instance variable | Aaron Patterson | 2012-01-23 | 1 | -1/+4 | |
| | | | ||||||
* | | | Added custom regexps to ASTs that have literal nodes on either side of | Aaron Patterson | 2012-01-23 | 1 | -1/+20 | |
| | | | | | | | | | | | | symbol nodes. Fixes #4585 | |||||
* | | | updated the warning signature | Aaron Patterson | 2012-01-23 | 1 | -1/+1 | |
| | | | ||||||
* | | | Deprecated multi args to http route methods | Aaron Patterson | 2012-01-23 | 1 | -0/+11 | |
| | | | ||||||
* | | | stop splatting so much. We don't need :star:args everywhere | Aaron Patterson | 2012-01-20 | 1 | -7/+6 | |
| | | | ||||||
* | | | We should finalize the routes as soon as possible and not wait for the ↵ | José Valim | 2012-01-06 | 1 | -2/+0 | |
| | | | | | | | | | | | | controller to be loaded. | |||||
* | | | Override respond_to? since we are also overriding method_missing. | José Valim | 2012-01-03 | 1 | -0/+4 | |
| | | | ||||||
* | | | Clean up routes inclusion and add some comments for the next soul that ↵ | José Valim | 2012-01-03 | 2 | -41/+49 | |
| | | | | | | | | | | | | decides to adventure on this code. | |||||
* | | | be explicit about where helpers are installed | Aaron Patterson | 2011-12-30 | 1 | -1/+1 | |
| | | | ||||||
* | | | just add the writer rather than adding both and removing one | Aaron Patterson | 2011-12-29 | 1 | -2/+1 | |
| | | | ||||||
* | | | stop using __send__ and just module eval in the extensions | Aaron Patterson | 2011-12-29 | 1 | -3/+2 | |
| | | | ||||||
* | | | we know the classes will be a list, so *tell* it to respond to each | Aaron Patterson | 2011-12-29 | 1 | -3/+3 | |
| | | | | | | | | | | | | rather than casting | |||||
* | | | don't need the begin / end | Aaron Patterson | 2011-12-29 | 1 | -21/+17 | |
| | | | ||||||
* | | | avoid extra method calls by just defining the delegate | Aaron Patterson | 2011-12-29 | 1 | -2/+3 | |
| | | | ||||||
* | | | don't use instance eval, just reference variables so we don't have to | Aaron Patterson | 2011-12-29 | 1 | -10/+11 | |
| | | | | | | | | | | | | worry about "inspect" marshalling | |||||
* | | | Merge branch 'master' of github.com:lifo/docrails | Vijay Dev | 2011-12-29 | 1 | -0/+7 | |
|\ \ \ | ||||||
| * | | | Documented about using :path option for resources | Kevin Moore | 2011-12-28 | 1 | -0/+7 | |
| | | | |