aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hooklist.bb
diff options
context:
space:
mode:
Diffstat (limited to 'doc/hooklist.bb')
-rw-r--r--doc/hooklist.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/doc/hooklist.bb b/doc/hooklist.bb
index 5226e7de6..863824590 100644
--- a/doc/hooklist.bb
+++ b/doc/hooklist.bb
@@ -145,6 +145,9 @@ Hooks allow plugins/addons to "hook into" the code at many points and alter the
[zrl=[baseurl]/help/hook/cron_weekly]cron_weekly[/zrl]
Called when weekly scheduled tasks are executed
+[zrl=[baseurl]/help/hook/crypto_methods]crypto_methods[/zrl]
+ Called when generating a list of crypto algorithms in the locally preferred order
+
[zrl=[baseurl]/help/hook/directory_item]directory_item[/zrl]
Called when generating a directory listing for display
@@ -386,6 +389,12 @@ Hooks allow plugins/addons to "hook into" the code at many points and alter the
[zrl=[baseurl]/help/hook/oembed_probe]oembed_probe[/zrl]
Called when performing an oembed content lookup
+[zrl=[baseurl]/help/hook/other_encapsulate]other_encapsulate[/zrl]
+ Called when encrypting content for which the algorithm is unknown (see also crypto_methods)
+
+[zrl=[baseurl]/help/hook/other_unencapsulate]other_unencapsulate[/zrl]
+ Called when decrypting content for which the algorithm is unknown (see also crypto_methods)
+
[zrl=[baseurl]/help/hook/page_content_top]page_content_top[/zrl]
Called when we generate a webpage (before calling the module content function)
@@ -533,6 +542,9 @@ Hooks allow plugins/addons to "hook into" the code at many points and alter the
[zrl=[baseurl]/help/hook/smilie]smilie[/zrl]
Called when translating emoticons
+[zrl=[baseurl]/help/hook/stream_item]stream_item[/zrl]
+ Called for each item which is rendered for viewing via conversation()
+
[zrl=[baseurl]/help/hook/tagged]tagged[/zrl]
Called when a delivery is processed which results in you being tagged
@@ -545,6 +557,9 @@ Hooks allow plugins/addons to "hook into" the code at many points and alter the
[zrl=[baseurl]/help/hook/well_known]well_known[/zrl]
Called when accessing the '.well-known' special site addresses
+[zrl=[baseurl]/help/hook/zot_best_algorithm]zot_best_algorithm[/zrl]
+ Called when negotiating crypto algorithms with remote sites
+
[zrl=[baseurl]/help/hook/zid]zid[/zrl]
Called when adding the observer's zid to a URL