aboutsummaryrefslogtreecommitdiffstats
path: root/doc/faq_developers.bb
diff options
context:
space:
mode:
Diffstat (limited to 'doc/faq_developers.bb')
-rw-r--r--doc/faq_developers.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/doc/faq_developers.bb b/doc/faq_developers.bb
index 6591de3f2..027efe8f4 100644
--- a/doc/faq_developers.bb
+++ b/doc/faq_developers.bb
@@ -5,6 +5,7 @@
[h3]What does $a mean?[/h3]
$a is a class defined in boot.php and passed all around $Projectname as a global reference variable. It defines everything necessary for the $Projectname application: Server variables, URL arguments, page structures, layouts, content, installed plugins, output device info, theme info, identity of the observer and (potential) page owner ...
+
We don't ever create more than one instance and always modify the elements of the single instance. The mechanics of this are somewhat tricky. If you have a function that is passed $a and needs to modify $a you need to declare it as a reference with '&' e.g.
[code]function foo(&$a) { $a->something = 'x'; // whatever };