diff options
Diffstat (limited to 'doc/developer_function_primer.bb')
-rw-r--r-- | doc/developer_function_primer.bb | 8 |
1 files changed, 2 insertions, 6 deletions
diff --git a/doc/developer_function_primer.bb b/doc/developer_function_primer.bb index 373454440..183581361 100644 --- a/doc/developer_function_primer.bb +++ b/doc/developer_function_primer.bb @@ -1,4 +1,4 @@ -[b]Red development - some useful basic functions[/b]
+[b]$Projectname development - some useful basic functions[/b]
[b]get_account_id()[/b]
@@ -12,13 +12,9 @@ Returns authenticated numeric channel_id if authenticated and connected to a cha Returns authenticated string hash of Red global identifier, if authenticated via remote auth, or an empty string.
-[b]get_app()[/b]
-
-Returns the global app structure ($a).
-
[b]App::get_observer()[/b]
-(App:: is usually assigned to the global $a), so $a->get_observer() or get_app()->get_observer() - returns an xchan structure representing the current viewer if authenticated (locally or remotely).
+returns an xchan structure representing the current viewer if authenticated (locally or remotely).
[b]get_config($family,$key), get_pconfig($uid,$family,$key), get_xconfig($xchan_hash,$family,$key)[/b]
|