aboutsummaryrefslogtreecommitdiffstats
path: root/doc/developer/api_zot.bb
diff options
context:
space:
mode:
Diffstat (limited to 'doc/developer/api_zot.bb')
-rw-r--r--doc/developer/api_zot.bb27
1 files changed, 20 insertions, 7 deletions
diff --git a/doc/developer/api_zot.bb b/doc/developer/api_zot.bb
index f33faed17..b2c19d7a1 100644
--- a/doc/developer/api_zot.bb
+++ b/doc/developer/api_zot.bb
@@ -4,7 +4,20 @@ The API endpoints detailed below are relative to [code]api/z/1.0[/code], meaning
[h3]channel/export/basic[/h3]
-Export channel data
+Export basic channel data
+
+Options:
+ - sections
+ comma-separated list of data types to export
+
+ - posts
+ if true, return default sections plus 3 months of posts
+
+ If no sections are requested, the following sections are returned:
+ channel, connections, config, apps, chatrooms, events, webpages, mail, wikis
+
+ Files and large collections of posts may run into memory limits; these must generally be
+ requested separately.
[h3]channel/stream[/h3]
@@ -28,7 +41,7 @@ GET /api/z/1.0/files
Options:
- - hash
+ - filehash
return only entries matching hash (exactly)
- filename
@@ -286,7 +299,7 @@ list photo metadata
[h3]group[/h3]
-`GET /api/z/1.0/group`
+[code]GET /api/z/1.0/group[/code]
Description: list privacy groups
@@ -326,7 +339,7 @@ To use with API group_members, provide either 'group_id' from the id element ret
[h3]group_members[/h3]
-`GET /api/z/1.0/group_members`
+[code]GET /api/z/1.0/group_members[/code]
Required:
@@ -462,7 +475,7 @@ group_member+abook+xchan (DB join) for each member of the privacy group
An xchan is a global location independent channel and is the primary record for a network
identity. It may refer to channels on other websites, networks, or services.
-`GET /api/z/1.0/xchan`
+[code]GET /api/z/1.0/xchan[/code]
Required: one of [ address, hash, guid ] as GET parameters
@@ -506,7 +519,7 @@ Returns:
Create or update an item (post, activity, webpage, etc.)
-Usage: `POST /api/z/1.0/item/update`
+Usage: [code]POST /api/z/1.0/item/update[/code]
Description: item/update posts an item (typically a conversation item or post, but can be any item) using form input.
@@ -608,7 +621,7 @@ Optional:
application or network name to display with item
-- categories
+- category
comma separated categories for this item