aboutsummaryrefslogtreecommitdiffstats
path: root/doc/plugins.bb
diff options
context:
space:
mode:
authorfriendica <info@friendica.com>2015-01-28 20:56:04 -0800
committerfriendica <info@friendica.com>2015-01-28 20:56:04 -0800
commita4960360669daa0a0c842427185ce1ada3b4ab97 (patch)
tree53feb1009266a77ee5338cc49919e45cca4b5ca6 /doc/plugins.bb
parent54fd8b21db2d8f3841cf590f88611a1d4f44ce48 (diff)
downloadvolse-hubzilla-a4960360669daa0a0c842427185ce1ada3b4ab97.tar.gz
volse-hubzilla-a4960360669daa0a0c842427185ce1ada3b4ab97.tar.bz2
volse-hubzilla-a4960360669daa0a0c842427185ce1ada3b4ab97.zip
local_user => local_channel
Diffstat (limited to 'doc/plugins.bb')
-rw-r--r--doc/plugins.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/doc/plugins.bb b/doc/plugins.bb
index 06801eb20..7f1684117 100644
--- a/doc/plugins.bb
+++ b/doc/plugins.bb
@@ -91,10 +91,10 @@ Let's go ahead and add some code to implement our post_local hook handler.
logger('randplace invoked');
- if(! local_user()) /* non-zero if this is a logged in user of this system */
+ if(! local_channel()) /* non-zero if this is a logged in user of this system */
return;
- if(local_user() != $item['uid']) /* Does this person own the post? */
+ if(local_channel() != $item['uid']) /* Does this person own the post? */
return;
if(($item['parent']) || ($item['item_restrict'])) {
@@ -104,7 +104,7 @@ Let's go ahead and add some code to implement our post_local hook handler.
/* Retrieve our personal config setting */
- $active = get_pconfig(local_user(), 'randplace', 'enable');
+ $active = get_pconfig(local_channel(), 'randplace', 'enable');
if(! $active)
return;
@@ -146,10 +146,10 @@ Now let's add our functions to create and store preference settings.
*/
function randplace_settings_post($a,$post) {
- if(! local_user())
+ if(! local_channel())
return;
if($_POST['randplace-submit'])
- set_pconfig(local_user(),'randplace','enable',intval($_POST['randplace']));
+ set_pconfig(local_channel(),'randplace','enable',intval($_POST['randplace']));
}
@@ -173,7 +173,7 @@ Now let's add our functions to create and store preference settings.
function randplace_settings(&amp;$a,&amp;$s) {
- if(! local_user())
+ if(! local_channel())
return;
/* Add our stylesheet to the page so we can make our settings look nice */
@@ -182,7 +182,7 @@ Now let's add our functions to create and store preference settings.
/* Get the current state of our config variable */
- $enabled = get_pconfig(local_user(),'randplace','enable');
+ $enabled = get_pconfig(local_channel(),'randplace','enable');
$checked = (($enabled) ? ' checked=&quot;checked&quot; ' : '');