aboutsummaryrefslogtreecommitdiffstats
path: root/doc/plugins.bb
diff options
context:
space:
mode:
authorfriendica <info@friendica.com>2015-01-29 15:09:35 -0800
committerfriendica <info@friendica.com>2015-01-29 15:09:35 -0800
commit912be23e1627211fb417c4b7bced414cbbe38ef0 (patch)
tree2b8567d800624167b3eadf37c8855deb0ba74b0b /doc/plugins.bb
parentff68ea608786a698ad46637ef13854ac1b1e6beb (diff)
parent872b165eb2bb5d632a12f2d7e1a28e195c2d5348 (diff)
downloadvolse-hubzilla-912be23e1627211fb417c4b7bced414cbbe38ef0.tar.gz
volse-hubzilla-912be23e1627211fb417c4b7bced414cbbe38ef0.tar.bz2
volse-hubzilla-912be23e1627211fb417c4b7bced414cbbe38ef0.zip
Merge branch 'master' into tres
Conflicts: include/group.php include/text.php mod/acl.php mod/channel.php mod/connections.php mod/display.php mod/group.php mod/item.php mod/locs.php mod/network.php mod/photos.php mod/ping.php mod/starred.php mod/viewsrc.php
Diffstat (limited to 'doc/plugins.bb')
-rw-r--r--doc/plugins.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/doc/plugins.bb b/doc/plugins.bb
index 06801eb20..7f1684117 100644
--- a/doc/plugins.bb
+++ b/doc/plugins.bb
@@ -91,10 +91,10 @@ Let's go ahead and add some code to implement our post_local hook handler.
logger('randplace invoked');
- if(! local_user()) /* non-zero if this is a logged in user of this system */
+ if(! local_channel()) /* non-zero if this is a logged in user of this system */
return;
- if(local_user() != $item['uid']) /* Does this person own the post? */
+ if(local_channel() != $item['uid']) /* Does this person own the post? */
return;
if(($item['parent']) || ($item['item_restrict'])) {
@@ -104,7 +104,7 @@ Let's go ahead and add some code to implement our post_local hook handler.
/* Retrieve our personal config setting */
- $active = get_pconfig(local_user(), 'randplace', 'enable');
+ $active = get_pconfig(local_channel(), 'randplace', 'enable');
if(! $active)
return;
@@ -146,10 +146,10 @@ Now let's add our functions to create and store preference settings.
*/
function randplace_settings_post($a,$post) {
- if(! local_user())
+ if(! local_channel())
return;
if($_POST['randplace-submit'])
- set_pconfig(local_user(),'randplace','enable',intval($_POST['randplace']));
+ set_pconfig(local_channel(),'randplace','enable',intval($_POST['randplace']));
}
@@ -173,7 +173,7 @@ Now let's add our functions to create and store preference settings.
function randplace_settings(&amp;$a,&amp;$s) {
- if(! local_user())
+ if(! local_channel())
return;
/* Add our stylesheet to the page so we can make our settings look nice */
@@ -182,7 +182,7 @@ Now let's add our functions to create and store preference settings.
/* Get the current state of our config variable */
- $enabled = get_pconfig(local_user(),'randplace','enable');
+ $enabled = get_pconfig(local_channel(),'randplace','enable');
$checked = (($enabled) ? ' checked=&quot;checked&quot; ' : '');