aboutsummaryrefslogtreecommitdiffstats
path: root/doc/hooklist.bb
diff options
context:
space:
mode:
authorDM42.Net (Matt Dent) <dentm42@dm42.net>2018-12-14 20:20:26 -0500
committerDM42.Net (Matt Dent) <dentm42@dm42.net>2018-12-14 20:20:26 -0500
commit09b2cdd618217c2dfc0149579ce1780c201a50ea (patch)
treec32cba336c19e08f5ec2fc4389c176b52ca1adf0 /doc/hooklist.bb
parentf81a3ba45d50c0a0e4da68c17aba73425058e23d (diff)
downloadvolse-hubzilla-09b2cdd618217c2dfc0149579ce1780c201a50ea.tar.gz
volse-hubzilla-09b2cdd618217c2dfc0149579ce1780c201a50ea.tar.bz2
volse-hubzilla-09b2cdd618217c2dfc0149579ce1780c201a50ea.zip
Add ITEM_TYPE_CUSTOM and hooks for processing custom item types
Diffstat (limited to 'doc/hooklist.bb')
-rw-r--r--doc/hooklist.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/doc/hooklist.bb b/doc/hooklist.bb
index 5d12a139e..08fc587e2 100644
--- a/doc/hooklist.bb
+++ b/doc/hooklist.bb
@@ -343,9 +343,18 @@ Hooks allow plugins/addons to "hook into" the code at many points and alter the
[zrl=[baseurl]/help/hook/item_store]item_store[/zrl]
Called when item_store() stores a record of type item
+[zrl=[baseurl]/help/hook/item_stored]item_stored[/zrl]
+ Called after item_store() has stored a record of type item in the database.
+
+[zrl=[baseurl]/help/hook/item_custom]item_custom[/zrl]
+ Called before item_store() stores a record of type item (allowing addons to process ITEM_TYPE_CUSTOM items).
+
[zrl=[baseurl]/help/hook/item_store_update]item_store_update[/zrl]
Called when item_store_update() is called to update a stored item.
+[zrl=[baseurl]/help/hook/item_stored_update]item_stored_update[/zrl]
+ Called after item_store_update() has updated a stored item.
+
[zrl=[baseurl]/help/hook/item_translate]item_translate[/zrl]
Called from item_store and item_store_update after the post language has been autodetected