aboutsummaryrefslogtreecommitdiffstats
path: root/doc/git_for_non_developers.bb
diff options
context:
space:
mode:
authorfriendica <info@friendica.com>2014-08-17 17:49:25 -0700
committerfriendica <info@friendica.com>2014-08-17 17:49:25 -0700
commitde1198ccfe113c848482ba0ba21bc9f24caca8a8 (patch)
tree0ffe71fd9ba4005d3c4141a496efcf933e51ddb4 /doc/git_for_non_developers.bb
parent82eb265a20d73beff7673299a6c4ab8a4d8b8673 (diff)
parent1ddbd44fb005f1bd1c7e9d22ab74d7cf378e2815 (diff)
downloadvolse-hubzilla-de1198ccfe113c848482ba0ba21bc9f24caca8a8.tar.gz
volse-hubzilla-de1198ccfe113c848482ba0ba21bc9f24caca8a8.tar.bz2
volse-hubzilla-de1198ccfe113c848482ba0ba21bc9f24caca8a8.zip
Merge https://github.com/friendica/red into pending_merge
Diffstat (limited to 'doc/git_for_non_developers.bb')
-rw-r--r--doc/git_for_non_developers.bb29
1 files changed, 27 insertions, 2 deletions
diff --git a/doc/git_for_non_developers.bb b/doc/git_for_non_developers.bb
index e68634da1..aa87fba69 100644
--- a/doc/git_for_non_developers.bb
+++ b/doc/git_for_non_developers.bb
@@ -41,6 +41,31 @@ This will open up an editor where you can describe the changes you have made. S
Finally, push the changes to your own git
[code]git push[/code]
-And that's it!
+And that's it, your repo is up to date!
-Return to the [url=[baseurl]/help/main]Main documentation page[/url] \ No newline at end of file
+All you need to do now is actually create the pull request. There are two ways to do this.
+
+The easy way, if you're using Github is to simply click the green button at the top of your own copy of the repository, enter a description of the changes, and click 'create pull request'. The
+main repository, themes, and addons all have their main branch at Github, so this method can be used most of the time.
+
+Most people can stop here.
+
+Some projects in the extended RedMatrix ecosphere have no Github presence, to pull request these is a bit different - you'll have to create your pull request manually. Fortunately, this isn't
+much harder.
+
+[code]git request-pull -p <start> <url>[/code]
+
+Start is the name of a commit to start at. This must exist upstream. Normally, you just want master.
+
+URL is the URL of [i]your[/i] repo.
+
+One can also specify <end>. This defaults to HEAD.
+
+Example:
+[code]
+git request-pull master https://example.com/project
+[/code]
+
+And simply send the output to the project maintainer.
+
+Return to the [url=[baseurl]/help/main]Main documentation page[/url]