aboutsummaryrefslogtreecommitdiffstats
path: root/doc/faq_developers.bb
diff options
context:
space:
mode:
authorredmatrix <git@macgirvin.com>2016-03-31 16:06:03 -0700
committerredmatrix <git@macgirvin.com>2016-03-31 16:06:03 -0700
commit9abd95fad3784a10fc48bc40f9b8a75d7d74edda (patch)
tree3cf2eec6a29f384b80a8c607aa97172b84e37e62 /doc/faq_developers.bb
parent256c228efd249f2ce93405db8e36f52030aa4876 (diff)
downloadvolse-hubzilla-9abd95fad3784a10fc48bc40f9b8a75d7d74edda.tar.gz
volse-hubzilla-9abd95fad3784a10fc48bc40f9b8a75d7d74edda.tar.bz2
volse-hubzilla-9abd95fad3784a10fc48bc40f9b8a75d7d74edda.zip
static App
Diffstat (limited to 'doc/faq_developers.bb')
-rw-r--r--doc/faq_developers.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/doc/faq_developers.bb b/doc/faq_developers.bb
index 603cf238f..5da2c19ff 100644
--- a/doc/faq_developers.bb
+++ b/doc/faq_developers.bb
@@ -8,22 +8,22 @@ $a is a class defined in boot.php and passed all around $Projectname as a global
We don't ever create more than one instance and always modify the elements of the single instance. The mechanics of this are somewhat tricky. If you have a function that is passed $a and needs to modify $a you need to declare it as a reference with '&' e.g.
-[code]function foo(&$a) { $a->something = 'x'; // whatever };
+[code]function foo(&$a) { App::$something = 'x'; // whatever };
*or* access it within your function as a global variable via get_app()
function foo() {
$a = get_app();
- $a->something = 'x';
+ App::$something = 'x';
}
-function foo($a) { $a->something = 'x'; };
+function foo($a) { App::$something = 'x'; };
will *not* change the global app state.
function foo() {
- get_app()->something = 'x';
+ App::$something = 'x';
}
[/code]