aboutsummaryrefslogtreecommitdiffstats
path: root/doc/faq_developers.bb
diff options
context:
space:
mode:
authorredmatrix <redmatrix@redmatrix.me>2015-05-13 19:23:13 -0700
committerredmatrix <redmatrix@redmatrix.me>2015-05-13 19:23:13 -0700
commit51b89f0ed8833004cf695de90791d8d0eec550b5 (patch)
tree815c33e71b411e6f2b8c44ba0f619ee8a869d912 /doc/faq_developers.bb
parent475dc7b686d6939d88c79dd58df1ff751356a922 (diff)
parentf866a42a42b9e12756353f5bb39a0f31a64bb26a (diff)
downloadvolse-hubzilla-51b89f0ed8833004cf695de90791d8d0eec550b5.tar.gz
volse-hubzilla-51b89f0ed8833004cf695de90791d8d0eec550b5.tar.bz2
volse-hubzilla-51b89f0ed8833004cf695de90791d8d0eec550b5.zip
Merge branch 'master' of https://github.com/redmatrix/redmatrix
Conflicts: doc/DerivedTheme1.md doc/Developers.md doc/Features.md doc/Plugins.md doc/Privacy.md doc/README.md doc/Remove-Account.md doc/Translations.md doc/about.bb doc/account_basics.bb doc/accounts_profiles_channels_basics.bb doc/addons.bb doc/addons_gnusocial.bb doc/bbcode.html doc/campaign.bb doc/classRedmatrix_1_1Import_1_1Import-members.html doc/classRedmatrix_1_1Import_1_1Import.html doc/cloud.bb doc/connecting_to_channels.bb doc/connecting_to_channels.md doc/credits.bb doc/de/channels.bb doc/de/features.bb doc/de/main.bb doc/de/registration.bb doc/developers.bb doc/encryption.bb doc/external-resource-links.bb doc/extra_features.bb doc/faq_admins.bb doc/faq_developers.bb doc/faq_members.bb doc/features.bb doc/hidden_configs.bb doc/history.md doc/html/index.php doc/main.bb doc/permissions.bb doc/plugins.bb doc/problems-following-an-update.bb doc/profiles.bb doc/red2pi.bb doc/registration.bb doc/roadmap.bb doc/sv/main.bb doc/what_is_zot.bb doc/zot.md
Diffstat (limited to 'doc/faq_developers.bb')
-rw-r--r--doc/faq_developers.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/doc/faq_developers.bb b/doc/faq_developers.bb
index 55d90621b..027efe8f4 100644
--- a/doc/faq_developers.bb
+++ b/doc/faq_developers.bb
@@ -4,7 +4,8 @@
[h3]What does $a mean?[/h3]
-$a is a class defined in boot.php and passed all around Hubzilla as a global reference variable. It defines everything necessary for the Hubzilla application: Server variables, URL arguments, page structures, layouts, content, installed plugins, output device info, theme info, identity of the observer and (potential) page owner ...
+$a is a class defined in boot.php and passed all around $Projectname as a global reference variable. It defines everything necessary for the $Projectname application: Server variables, URL arguments, page structures, layouts, content, installed plugins, output device info, theme info, identity of the observer and (potential) page owner ...
+
We don't ever create more than one instance and always modify the elements of the single instance. The mechanics of this are somewhat tricky. If you have a function that is passed $a and needs to modify $a you need to declare it as a reference with '&' e.g.
[code]function foo(&$a) { $a->something = 'x'; // whatever };