aboutsummaryrefslogtreecommitdiffstats
path: root/doc/faq_developers.bb
diff options
context:
space:
mode:
authorredmatrix <redmatrix@redmatrix.me>2015-05-05 03:59:51 -0700
committerredmatrix <redmatrix@redmatrix.me>2015-05-05 03:59:51 -0700
commit5b5f0666f9addc4b2c0cd69495d9fe8f76011ee2 (patch)
tree77f218c70fb424a0e473b76159a89a87de0ec683 /doc/faq_developers.bb
parenta3c37f145817407df28e9ffea6a83a6cd2b31cdd (diff)
downloadvolse-hubzilla-5b5f0666f9addc4b2c0cd69495d9fe8f76011ee2.tar.gz
volse-hubzilla-5b5f0666f9addc4b2c0cd69495d9fe8f76011ee2.tar.bz2
volse-hubzilla-5b5f0666f9addc4b2c0cd69495d9fe8f76011ee2.zip
second pass name change
Diffstat (limited to 'doc/faq_developers.bb')
-rw-r--r--doc/faq_developers.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/faq_developers.bb b/doc/faq_developers.bb
index 010ef9b8a..55d90621b 100644
--- a/doc/faq_developers.bb
+++ b/doc/faq_developers.bb
@@ -4,7 +4,7 @@
[h3]What does $a mean?[/h3]
-$a is a class defined in boot.php and passed all around Red Matrix as a global reference variable. It defines everything necessary for the Red Matrix application: Server variables, URL arguments, page structures, layouts, content, installed plugins, output device info, theme info, identity of the observer and (potential) page owner ...
+$a is a class defined in boot.php and passed all around Hubzilla as a global reference variable. It defines everything necessary for the Hubzilla application: Server variables, URL arguments, page structures, layouts, content, installed plugins, output device info, theme info, identity of the observer and (potential) page owner ...
We don't ever create more than one instance and always modify the elements of the single instance. The mechanics of this are somewhat tricky. If you have a function that is passed $a and needs to modify $a you need to declare it as a reference with '&' e.g.
[code]function foo(&$a) { $a->something = 'x'; // whatever };