aboutsummaryrefslogtreecommitdiffstats
path: root/doc/faq_developers.bb
diff options
context:
space:
mode:
authorTobias Luther <tobias@bitratemag.cc>2014-06-29 21:07:42 +0200
committerTobias Luther <tobias@bitratemag.cc>2014-06-29 21:07:42 +0200
commit1a118a08288fcf6f4a84f2996a0adf5b0b7d9aa5 (patch)
treea1ea256ef5966a6ff8191498dbbfdc3434c5ceea /doc/faq_developers.bb
parenta47971aefd2bee45f4e57dd1fc3ea24bb370881f (diff)
downloadvolse-hubzilla-1a118a08288fcf6f4a84f2996a0adf5b0b7d9aa5.tar.gz
volse-hubzilla-1a118a08288fcf6f4a84f2996a0adf5b0b7d9aa5.tar.bz2
volse-hubzilla-1a118a08288fcf6f4a84f2996a0adf5b0b7d9aa5.zip
Tidied the folder from old backups
created new files for a quick explanation of the use of accounts, profiles, channels added FAQ for users, admins and developers (the last one might not be exactly necessary?) created a file to explain posting for new users created new file to explain nomadic identities for users modified main.bb
Diffstat (limited to 'doc/faq_developers.bb')
-rw-r--r--doc/faq_developers.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/faq_developers.bb b/doc/faq_developers.bb
new file mode 100644
index 000000000..192dcb5c5
--- /dev/null
+++ b/doc/faq_developers.bb
@@ -0,0 +1,28 @@
+[size=large][b]Frequently Asked Questions For Developers[/b][/size]
+
+(...) still needs to be written (...)
+
+[ul]
+[*][b]What does $a mean?[/b]
+$a is a class defined in boot.php and passed all around Red Matrix as a global reference variable. It defines everything necessary for the Red Matrix application: Server variables, URL arguments, page structures, layouts, content, installed plugins, output device info, theme info, identity of the observer and (potential) page owner ...
+We don't ever create more than one instance and always modify the elements of the single instance. The mechanics of this are somewhat tricky. If you have a function that is passed $a and needs to modify $a you need to declare it as a reference with '&' e.g.
+
+[code]function foo(&$a) { $a->something = 'x'; // whatever };
+
+*or* access it within your function as a global variable via get_app()
+
+function foo() {
+ $a = get_app();
+ $a->something = 'x';
+}
+
+
+function foo($a) { $a->something = 'x'; };
+
+will *not* change the global app state.
+
+function foo() {
+ get_app()->something = 'x';
+}
+[/code]
+[/ul]