aboutsummaryrefslogtreecommitdiffstats
path: root/doc/en/api/statuses_update.bb
diff options
context:
space:
mode:
authorMario <mario@mariovavti.com>2024-07-06 11:05:22 +0000
committerMario <mario@mariovavti.com>2024-07-06 11:05:22 +0000
commit45275910e606a02b12393714ea3b0409da440d61 (patch)
tree10b2d173d58cb930f8df28fe75af73dd4974c08c /doc/en/api/statuses_update.bb
parent0c1d0f7498661fb34dcca6f3c6566e757af310a7 (diff)
parentc04e781926a78e514cdf211fa24930a331149072 (diff)
downloadvolse-hubzilla-45275910e606a02b12393714ea3b0409da440d61.tar.gz
volse-hubzilla-45275910e606a02b12393714ea3b0409da440d61.tar.bz2
volse-hubzilla-45275910e606a02b12393714ea3b0409da440d61.zip
Merge branch '9.2RC'master
Diffstat (limited to 'doc/en/api/statuses_update.bb')
-rw-r--r--doc/en/api/statuses_update.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/doc/en/api/statuses_update.bb b/doc/en/api/statuses_update.bb
new file mode 100644
index 000000000..acad440de
--- /dev/null
+++ b/doc/en/api/statuses_update.bb
@@ -0,0 +1,23 @@
+[h2]statuses/update[/h2]
+Parameters
+
+ title: Title of the status
+ status: Status in text [or bbcode] format
+ htmlstatus: Status in HTML format
+ in_reply_to_status_id
+ lat: latitude
+ long: longitude
+ media: image data
+ source: Application name
+ group_allow
+ contact_allow
+ group_deny
+ contact_deny
+
+
+Example
+
+[code]
+curl -u theUsername:thePassword http://mywebsite/api/statuses/update.xml -d status='Hello world'
+[/code]
+