aboutsummaryrefslogtreecommitdiffstats
path: root/doc/dev_beginner.bb
diff options
context:
space:
mode:
authoreinervonvielen <tomwie@users.sourceforge.net>2015-02-15 18:11:51 +0100
committereinervonvielen <tomwie@users.sourceforge.net>2015-02-15 18:11:51 +0100
commit4e6ba149d70cc4d3ae915cb0d0f298c74e408527 (patch)
tree3e8ad69d92c77fa6b62e5496ded3c5706164d5de /doc/dev_beginner.bb
parent6ed8fb30b8b6b70c1f9a2ff5651d6a4892060db9 (diff)
downloadvolse-hubzilla-4e6ba149d70cc4d3ae915cb0d0f298c74e408527.tar.gz
volse-hubzilla-4e6ba149d70cc4d3ae915cb0d0f298c74e408527.tar.bz2
volse-hubzilla-4e6ba149d70cc4d3ae915cb0d0f298c74e408527.zip
Some changes of doc for beginning developers
Made some corrections after following this manual step by step.
Diffstat (limited to 'doc/dev_beginner.bb')
-rw-r--r--doc/dev_beginner.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/doc/dev_beginner.bb b/doc/dev_beginner.bb
index c3e4ea07c..b29b0bad7 100644
--- a/doc/dev_beginner.bb
+++ b/doc/dev_beginner.bb
@@ -188,8 +188,7 @@ If you not want to use GIT from the command line - there is a usefull Eclipse pl
You should have created an account on github and forked the projects befor you procceed.
Delete the directory www
-[code]root@debian /var/www/html $ cd ..
-rm -R www/
+[code]root@debian:/var# rm -R www/
[/code]
Install git (and optionally git-gui a client gui)
@@ -211,7 +210,7 @@ root@debian:/var/www# mkdir -p "store/[data]/smarty3"
Create .htconfig.php and make it writable by the webserver
[code]
-root@debian:/var# cd www/
+root@debian:/var/www# touch .htconfig.php
root@debian:/var/www# chmod ou+w .htconfig.php
[/code]
@@ -224,6 +223,7 @@ root@debian:/var# chown -R www-data:www-data www/
Add yourself ("surfer" in this example) to the group www-data. Why? Later you want to modify files in eclipse or in another editor.
Then make all files writable by the group www-date you are now a member of.
[code]
+root@debian:/var# cd www/
root@debian:/var/www# usermod -G www-data surfer
root@debian:/var# chmod -R g+w www/
[/code]