aboutsummaryrefslogtreecommitdiffstats
path: root/doc/dav_mount.bb
diff options
context:
space:
mode:
authorThomas Willingham <founder@kakste.com>2014-02-24 05:13:28 +0000
committerThomas Willingham <founder@kakste.com>2014-02-24 05:13:28 +0000
commit29f6975715b20597c6e19945ca5095f1e60dad42 (patch)
tree3def6931fd6249d546d822ee57298bb45ce05b90 /doc/dav_mount.bb
parent8284901f9eda97457da1d4d5a74a0e24ee9249b3 (diff)
downloadvolse-hubzilla-29f6975715b20597c6e19945ca5095f1e60dad42.tar.gz
volse-hubzilla-29f6975715b20597c6e19945ca5095f1e60dad42.tar.bz2
volse-hubzilla-29f6975715b20597c6e19945ca5095f1e60dad42.zip
Import doco from docs@friendicared.net
Diffstat (limited to 'doc/dav_mount.bb')
-rw-r--r--doc/dav_mount.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/doc/dav_mount.bb b/doc/dav_mount.bb
new file mode 100644
index 000000000..f86e2a6e5
--- /dev/null
+++ b/doc/dav_mount.bb
@@ -0,0 +1,63 @@
+[b]Mounting As A Filesystem[/b]
+
+To install your cloud directory as a filesystem, you first need davfs2 installed. 99% of the time, this will be included in your distributions repositories. In Debian
+
+[code]apt-get install davfs2[/code]
+
+If you want to let normal users mount the filesystem
+
+[code] dpkg-reconfigure davfs2[/code]
+
+and select &quot;yes&quot; at the prompt.
+
+Now you need to add any user you want to be able to mount dav to the davfs2 group
+
+[code]usermod -aG davfs2 &lt;DesktopUser&gt;[/code]
+
+Edit /etc/fstab
+
+[code]nano /etc/fstab[/code]
+
+ to include your cloud directory by adding
+
+[code]
+example.com/cloud/ /mount/point davfs user,noauto,uid=&lt;DesktopUser&gt;,file_mode=600,dir_mode=700 0 1
+[/code]
+
+Where example.com is the URL of your hub, /mount/point is the location you want to mount the cloud, and &lt;DesktopUser&gt; is the user you log in to one your computer. Note that if you are mounting as a normal user (not root) the mount point must be in your home directory.
+
+For example, if I wanted to mount my cloud to a directory called 'cloud' in my home directory, and my username was bob, my fstab would be
+
+[code]example.com/cloud/ /home/bob/cloud davfs user,noauto,uid=bob,file_mode=600,dir_mode=700 0 1[/code]
+
+Now, create the mount point.
+
+[code]mkdir /home/bob/cloud[/code]
+
+and also create a directory file to store your credentials
+
+[code]mkdir /home/bob/.davfs2[/code]
+
+Create a file called 'secrets'
+
+[code]nano /home/bob/.davfs2/secrets[/code]
+
+and add your cloud login credentials
+
+[code]
+example.com/cloud &lt;username&gt; &lt;password&gt;
+[/code]
+
+Where &lt;username&gt; and &lt;password&gt; are the username and password [i]for your hub[/i].
+
+Don't let this file be writeable by anyone who doesn't need it with
+
+[code]chmod 600 /home/bob/.davfs2/secrets[/code]
+
+Finally, mount the drive.
+
+[code]mount example.com/cloud[/code]
+
+You can now find your cloud at /home/bob/cloud and use it as though it were part of your local filesystem - even if the applications you are using have no dav support themselves.
+
+Return to the [zrl=[baseurl]/help/main]Main documentation page[/zrl] \ No newline at end of file