aboutsummaryrefslogtreecommitdiffstats
path: root/doc/api_posting.bb
diff options
context:
space:
mode:
authoranaqreon <tamanning@zoho.com>2014-12-30 16:06:35 -0600
committeranaqreon <tamanning@zoho.com>2014-12-30 16:06:35 -0600
commitb78a545a1056e6db9f4b6b4f262182b0a5c56e67 (patch)
tree515c2f742a5a39e18b00debf1849ee9703fa4a42 /doc/api_posting.bb
parentd67c5a6ffd134602084a6dcb37b316bf768bf715 (diff)
parent43671a0a323afa758df56c06822ce3c46da026df (diff)
downloadvolse-hubzilla-b78a545a1056e6db9f4b6b4f262182b0a5c56e67.tar.gz
volse-hubzilla-b78a545a1056e6db9f4b6b4f262182b0a5c56e67.tar.bz2
volse-hubzilla-b78a545a1056e6db9f4b6b4f262182b0a5c56e67.zip
Merge pull request #1 from friendica/master
Pull from upstream
Diffstat (limited to 'doc/api_posting.bb')
-rw-r--r--doc/api_posting.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/doc/api_posting.bb b/doc/api_posting.bb
index eeb7127fd..fa9558268 100644
--- a/doc/api_posting.bb
+++ b/doc/api_posting.bb
@@ -2,7 +2,7 @@
The API allows you to post to the red# by HTTP POST request. Below you see an example using the command line tool cURL:
-[code]curl -ssl -u [color=blue]$E-Mail[/color]:[color=blue]$Password[/color] -d "[color=blue]$Parameters[/color]" [url][observer.baseurl]/api/statuses/update
+[code]curl -ssl -u [color=blue]$E-Mail[/color]:[color=blue]$Password[/color] -d "[color=blue]$Parameters[/color]" [url][observer=1][observer.baseurl][/observer][observer=0]example.com[/observer]/api/statuses/update
[/url][/code]
[table][tr][td]$E-Mail:[/td][td]The E-Mail Adress you use to login[/td][/tr]
[tr][td]$Password:[/td][td]The Password you use to login[/td][/tr]
@@ -18,6 +18,6 @@ The API allows you to post to the red# by HTTP POST request. Below you see an ex
[/ul]
-Instead of calling [observer.baseurl]/api/statuses/update which returns a json (you could also add .json on the end to clarify) output, you can use [observer.baseurl]/api/statuses/update.xml to get an xml formatted return.
+Instead of calling [observer=1][observer.baseurl][/observer][observer=0]example.com[/observer]/api/statuses/update which returns a json (you could also add .json on the end to clarify) output, you can use [observer.baseurl]/api/statuses/update.xml to get an xml formatted return.
-Instead of Basic HTTP Authentification you could also use oAuth. \ No newline at end of file
+Instead of Basic HTTP Authentification you could also use oAuth.