aboutsummaryrefslogtreecommitdiffstats
path: root/doc/api_posting.bb
diff options
context:
space:
mode:
authorredmatrix <redmatrix@redmatrix.me>2015-10-11 12:41:39 -0700
committerredmatrix <redmatrix@redmatrix.me>2015-10-11 12:41:39 -0700
commit0f6e1c1c05ca59a0431173132c2c634b6c3c84fa (patch)
tree0c79bc1e5b1be9f626820eb5e26056a71efafbad /doc/api_posting.bb
parentce8d49a47d337422ef332a3e7fcd73547b3eb280 (diff)
parent22a5a91bd57bd81edcf1c4ccaba1e252f5eb23b4 (diff)
downloadvolse-hubzilla-0f6e1c1c05ca59a0431173132c2c634b6c3c84fa.tar.gz
volse-hubzilla-0f6e1c1c05ca59a0431173132c2c634b6c3c84fa.tar.bz2
volse-hubzilla-0f6e1c1c05ca59a0431173132c2c634b6c3c84fa.zip
Merge https://github.com/redmatrix/hubzilla into pending_merge
Diffstat (limited to 'doc/api_posting.bb')
-rw-r--r--doc/api_posting.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/doc/api_posting.bb b/doc/api_posting.bb
index fa9558268..c708ad143 100644
--- a/doc/api_posting.bb
+++ b/doc/api_posting.bb
@@ -4,19 +4,20 @@ The API allows you to post to the red# by HTTP POST request. Below you see an ex
[code]curl -ssl -u [color=blue]$E-Mail[/color]:[color=blue]$Password[/color] -d "[color=blue]$Parameters[/color]" [url][observer=1][observer.baseurl][/observer][observer=0]example.com[/observer]/api/statuses/update
[/url][/code]
-[table][tr][td]$E-Mail:[/td][td]The E-Mail Adress you use to login[/td][/tr]
+[table][tr][td]$E-Mail:[/td][td]The E-Mail Address you use to login, or the channel nickname (without the hostname)[/td][/tr]
[tr][td]$Password:[/td][td]The Password you use to login[/td][/tr]
[tr][td]$Parameters:[/td][td]That's the interesting part, here you insert the content you want to send using the following parameters:[/td][/tr][/table]
[ul]
[*]title: the title of the posting
-[*]channel: the channel you want to post to
+[*]channel: the channel you want to post to (do not use this parameter with HTTP Basic auth)
[*]category: a comma-seperated list of categories for the posting
[*]status: the content of the posting, formatted with BBCode
OR
[*]htmlstatus:the content of the posting, formatted in HTML.
[/ul]
+To post to a specific channel, replace the email address with the channel nickname. If you supply the channel parameter, it has to match the "email", but is superfluous anyway.
Instead of calling [observer=1][observer.baseurl][/observer][observer=0]example.com[/observer]/api/statuses/update which returns a json (you could also add .json on the end to clarify) output, you can use [observer.baseurl]/api/statuses/update.xml to get an xml formatted return.