diff options
author | Harald Eilertsen <haraldei@anduin.net> | 2021-07-05 22:03:47 +0200 |
---|---|---|
committer | Harald Eilertsen <haraldei@anduin.net> | 2021-07-05 22:03:47 +0200 |
commit | d08138ea633da76d9ca390e4f9e3c5489aee23d1 (patch) | |
tree | 80a682350c75d6e01f05144cf054e9d48edbed07 /Cargo.toml | |
parent | 098adf3a6895529bbd467f13b55fc241099c2ff7 (diff) | |
download | rust-zotapi-d08138ea633da76d9ca390e4f9e3c5489aee23d1.tar.gz rust-zotapi-d08138ea633da76d9ca390e4f9e3c5489aee23d1.tar.bz2 rust-zotapi-d08138ea633da76d9ca390e4f9e3c5489aee23d1.zip |
Update reqwest and make async.
This means adding the full tokio as a dependency. While there isn't much
gain to going async in the current cli demo app, a full fledged app may
have more to gain by it.
First foray into async rust, so I might not do it right...
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -23,10 +23,11 @@ edition = "2018" [dependencies] clap = "2.33.0" dotenv = "0.15" -reqwest = "0.9.1" +reqwest = { version = "0.11", features = ["default-tls", "multipart"] } serde = { version = "1.0", features = ["derive"] } serde_json = "1.0" serde_qs = "0.8" +tokio = { version = "1.8", features = ["full"] } url = "2.2" [dev-dependencies] |