diff options
author | redmatrix <redmatrix@redmatrix.me> | 2015-05-13 19:23:13 -0700 |
---|---|---|
committer | redmatrix <redmatrix@redmatrix.me> | 2015-05-13 19:23:13 -0700 |
commit | 51b89f0ed8833004cf695de90791d8d0eec550b5 (patch) | |
tree | 815c33e71b411e6f2b8c44ba0f619ee8a869d912 /doc/red2pi.bb | |
parent | 475dc7b686d6939d88c79dd58df1ff751356a922 (diff) | |
parent | f866a42a42b9e12756353f5bb39a0f31a64bb26a (diff) | |
download | volse-hubzilla-51b89f0ed8833004cf695de90791d8d0eec550b5.tar.gz volse-hubzilla-51b89f0ed8833004cf695de90791d8d0eec550b5.tar.bz2 volse-hubzilla-51b89f0ed8833004cf695de90791d8d0eec550b5.zip |
Merge branch 'master' of https://github.com/redmatrix/redmatrix
Conflicts:
doc/DerivedTheme1.md
doc/Developers.md
doc/Features.md
doc/Plugins.md
doc/Privacy.md
doc/README.md
doc/Remove-Account.md
doc/Translations.md
doc/about.bb
doc/account_basics.bb
doc/accounts_profiles_channels_basics.bb
doc/addons.bb
doc/addons_gnusocial.bb
doc/bbcode.html
doc/campaign.bb
doc/classRedmatrix_1_1Import_1_1Import-members.html
doc/classRedmatrix_1_1Import_1_1Import.html
doc/cloud.bb
doc/connecting_to_channels.bb
doc/connecting_to_channels.md
doc/credits.bb
doc/de/channels.bb
doc/de/features.bb
doc/de/main.bb
doc/de/registration.bb
doc/developers.bb
doc/encryption.bb
doc/external-resource-links.bb
doc/extra_features.bb
doc/faq_admins.bb
doc/faq_developers.bb
doc/faq_members.bb
doc/features.bb
doc/hidden_configs.bb
doc/history.md
doc/html/index.php
doc/main.bb
doc/permissions.bb
doc/plugins.bb
doc/problems-following-an-update.bb
doc/profiles.bb
doc/red2pi.bb
doc/registration.bb
doc/roadmap.bb
doc/sv/main.bb
doc/what_is_zot.bb
doc/zot.md
Diffstat (limited to 'doc/red2pi.bb')
-rw-r--r-- | doc/red2pi.bb | 28 |
1 files changed, 14 insertions, 14 deletions
diff --git a/doc/red2pi.bb b/doc/red2pi.bb index 5e2b77755..18e7d325a 100644 --- a/doc/red2pi.bb +++ b/doc/red2pi.bb @@ -1,4 +1,4 @@ -[b]How to install the Hubzilla on a Raspberry Pi[/b]
+[b]How to install the $Projectname on a Raspberry Pi[/b]
You just bought a Raspberry Pi and want to run the RED Matrix with your own domain name?
@@ -6,11 +6,11 @@ Then this page is for you! You will: [list=1]
[*] Install Raspberry OS (Debian Linux) on a Raspberry
[*] Install Apache Web Server, PHP, MaySQL, phpMyAdmin
-[*] Register a free domain (dynamic DNS) and use it for your RED hub
-[*] Install the RED Matrix
-[*] Keep your Raspberry Pi and your Hubzilla up-to-date
+[*] Register a free domain (dynamic DNS) and use it for your hub
+[*] Install $Projectname
+[*] Keep your Raspberry Pi and $Projectname up-to-date
[*] TODO Setting up SSL
-[*] TODO Running Friendica with SSL
+[*] TODO Running with SSL
[*] TODO Make the webserver less vulnarable to attacks
[/list]
@@ -224,27 +224,27 @@ To check the logs you can use this: [code]more /var/log/messages |grep INADYN[/code]
-[size=large]4. Install RED [/size]
+[size=large]4. Install $Projectname[/size]
-(Source: [zrl=https://friendicared.net/help/Install]https://friendicared.net/help/Install[/zrl])
+(Source: [zrl=[baseurl]/help/Install][baseurl]/help/Install[/zrl])
Linux Appache document root is /var/www/
Two files exist there (created by the steps above): index.html, phpinfo.php
-[b]Install RED and its Addons[/b]
+[b]Install $Projectname and its Addons[/b]
Cleanup: Remove the directory www/ (Git will not create files and folders in directories that are not empty.) Make sure you are in directory var[code]pi@pi /var $ cd /var[/code]
Remove directory[code]pi@pi /var $ sudo rm -rf www/[/code]
-Download the sources of RED from GIT
+Download the sources of $Projectname from GIT
[code]pi@pi /var $ sudo git clone https://github.com/redmatrix/hubzilla.git www[/code]
Download the sources of the addons from GIT
[code]pi@pi /var/www $ sudo git clone https://github.com/redmatrix/hubzilla-addons.git addon[/code]
-Make user www-data the owner of the whole red directory (including subdirectories and files)
+Make user www-data the owner of the whole web directory (including subdirectories and files)
(TODO: This step has to be proofed by the next installation.)
[code]pi@pi /var $ chown -R www-data:www-data /var/www/[/code]
@@ -319,14 +319,14 @@ php util/config system block_public_search 1 -[size=large]5. Keep your Raspberry Pi and your Hubzilla up-to-date[/size]
+[size=large]5. Keep your Raspberry Pi and your $Projectname up-to-date[/size]
-Git update of RED every day at 4 am and addons at 5 am every day
+Git update every day at 4 am and addons at 5 am every day
Try if the command is working
- pi@pi /var/www $ sudo git pull
Create the cronjob
- pi@pi /var/www $ crontab -e
-Enter the following to update RED at 4:01 am every day
+Enter the following to update at 4:01 am every day
- 01 04 * * * cd /var/www/; sudo git pull
Enter the following to update the addons at 5:01 am every day
- 01 05 * * * cd /var/www/addon/; sudo git pull
@@ -334,7 +334,7 @@ Enter the following to update the Raspberry Pi (Raspbian OS = Debian) at 6:01 am - 01 06 * * * sudo aptitude -y update && sudo aptitude -y safe-upgrade
Save and exit.
-[size=large]6. Running Friendica with SSL[/size]
+[size=large]6. Running with SSL[/size]
Follow the instructions here:
[url=https://github.com/friendica/friendica/wiki/Running-Friendica-with-SSL]https://github.com/friendica/friendica/wiki/Running-Friendica-with-SSL[/url]
|