aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorHarald Eilertsen <haraldei@anduin.net>2018-03-13 22:30:09 +0100
committerHarald Eilertsen <haraldei@anduin.net>2018-03-13 22:30:09 +0100
commit027e48928315c55e544f722bb39caec159e08964 (patch)
tree17bda587794bec5af89d512224d8979cadf1bb0b /Cargo.toml
downloadcheckpw-027e48928315c55e544f722bb39caec159e08964.tar.gz
checkpw-027e48928315c55e544f722bb39caec159e08964.tar.bz2
checkpw-027e48928315c55e544f722bb39caec159e08964.zip
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..c823e2d
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,27 @@
+# checkpw - Check passwords against pwnedpasswords.com
+# Copyright (C) 2018 Harald Eilertsen <haraldei@anduin.net>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+[package]
+name = "checkpw"
+version = "0.1.0"
+authors = ["Harald Eilertsen <haraldei@anduin.net>"]
+
+[dependencies]
+futures = "0.1"
+hyper = "0.11"
+hyper-tls = "0.1"
+ring = "0.12.1"
+tokio-core = "0.1"